GenSynth Documentation

Upgrade from 1.5.x Notes

Upgrade from 1.6.x notes also apply.

Regarding GSP-1116, check if the database hosts table contains duplicate entries. If so, we’ll develop a script to fix it up.

Logging configuration is no longer required. Customers are no longer able to see DEBUG logs. A decryption key is required to view these.

The application configuration section now requires the database type. If you do not set it, the default database type is sqlite3 (not recommended).

A backwards-compatible database upgrade is required before using GenSynth 1.8.0. You may upgrade the database before upgrading GenSynth. Obtain an upgrade script from Darwin AI.