GenSynth Documentation

GenSynth Release Notes 1.15

DarwinAI is pleased to present GenSynth 1.15.

GenSynth documentation is now online. You can always find the link in the user menu of GenSynth.

Please register as a user with our knowledge base. Ask your Darwin AI contact for access.

Highlights

Improvements

Resource Packages Updates

Resolved Issues

Contacting DarwinAI

To contact DarwinAI, go to https://www.darwinai.ca/contact.html and fill out the contact form.

Required Software

All GenSynth components must be upgraded together. The web UI, the API, and the database must all be running at version 1.15.0. We recommend updating all components together in a maintenance window.

You must have working installations of Docker and Nvidia Container Runtime. The current required versions are:

  • Docker 18.06.1-ce

  • Docker Compose 1.23.0+

  • Nvidia GPU Drivers 418.87.00

DarwinAI recommends TensorFlow versions 1.10.0-1.15.0.

Supported Databases:

  • MicroSoft SQL Server 2017+

  • PostgreSQL 11.4+

Supported Browsers:

  • Chrome 79, 81, 84

  • Microsoft Edge 84+

  • Firefox 79 +

GenSynth Software Versions

You must log in to Docker Hub (use the docker login command) to fetch the installation images. Your Docker Hub account must be registered with DarwinAI in order to pull the darwinai/gensynth images.

The current 1.15 images are:

  • darwinai/gensynth:api_1.15.0-gpu

  • darwinai/gensynth-web:1.15.0

  • darwinai/gensynth-db:1.15.0-pg for postgres, otherwise darwinai/gensynth-db:1.15.0-mssql for MS SQL server