GenSynth Documentation

Upgrade Notes

Upgrade from 1.14 Notes

If you have entities that start or end with spaces, or are entirely spaces, rename them before upgrading.

Upgrade from 1.12.x Notes

Upgrade from 1.14.x notes also apply.

If you are using the gensynth_deploy_scripts or Quick Install methods of running GenSynth, note that the location of the configuration files folder has been moved from gensynth -internals/var_lib_gensynth to gensynth-workspace/config. New jobs will place config files in the workspace.

Version 1.13.x uses a new database schema version 2.0.0 that is incompatible with earlier software versions. Update all components together.

Starting with GenSynth 1.13, the PostgreSQL container (e.g., darwinai/gensynth-db:1.13.0-pg) contains an upgrade script that will check the current version and attempt to upgrade it. So if you have shutdown a previous container version and started the new container version using the same database files, you can easily upgrade like this.

To discover if upgrades are available, run:

/gensynth-schema-upgrade/auto-upgrade.sh

If you wish to perform a single stage of upgrade, run:

/gensynth-schema-upgrade/auto-upgrade.sh --yes

If you wish to run all available upgrades in sequence, run:

/gensynth-schema-upgrade/auto-upgrade.sh --all

Read the output to see if any errors have occurred.

Upgrade from 1.11.x Notes

Upgrade from 1.12.x notes also apply.

A database schema upgrade is required if you are migrating a database from a previous release. The 1.12.x schema is backwards-compatible with 1.11.x, so you may do it before upgrading other components.

Upgrade from 1.10.x Notes

Upgrade from 1.11.x notes also apply.

Some additional configuration must be made for multi-machines deployments: see the Installation Guide for information about MPI and IPC Parameters and how to add the host name of the primary machine.

Database upgrade scripts must be applied if you are migrating a database from a previous release.

Upgrade from 1.9.x Notes

Upgrade from 1.10.x notes also apply.

Explain templates are no longer valid. You will need to re-create them.

Model entities now require you to specify Input Tensors. In the case of two-graph models, you must provide both Training Input Tensors and Evaluation Input Tensors. For any existing model entities you have, you must load, update, and re-save them.

Upgrade from 1.7.x Notes

Because of the new way of defining a model entity, previous jobs cannot be resumed or fine-tuned. You may work around this by defining a new model entity using the relevant save files.

Network templates no longer exist, since most of the information is available in Network Entities. Be sure you have the information you need about the network before upgrading.

Upgrade from 1.6.x Notes

Upgrade from 1.7.x notes also apply.

When upgrading from version 1.6.x or earlier, if you have a custom metrics script you will need to port it to the new module interface as a Custom Metric Entity.

Upgrade from 1.5.x Notes

Upgrade from 1.6.x notes also apply.

Regarding GSP-1116, check if the database hosts table contains duplicate entries. If so, we’ll develop a script to fix it up.

Logging configuration is no longer required. Customers are no longer able to see DEBUG logs. A decryption key is required to view these.

The application configuration section now requires the database type. If you do not set it, the default database type is sqlite3 (not recommended).

A backwards-compatible database upgrade is required before using GenSynth 1.8.0. You may upgrade the database before upgrading GenSynth. Obtain an upgrade script from Darwin AI.